雲雀は高く空を舞い このページをアンテナに追加 RSSフィード

「ひよこは高く空を舞い」について

2007-05-11

ruby (また)はじめました  ruby (また)はじめました - 雲雀は高く空を舞い を含むブックマーク はてなブックマーク -  ruby (また)はじめました - 雲雀は高く空を舞い  ruby (また)はじめました - 雲雀は高く空を舞い のブックマークコメント

にて。

[]apache2のモジュールロード apache2のモジュールロード - 雲雀は高く空を舞い を含むブックマーク はてなブックマーク - apache2のモジュールロード - 雲雀は高く空を舞い apache2のモジュールロード - 雲雀は高く空を舞い のブックマークコメント

ubuntuというよりapache2だけど。

a2enmod と a2dismod でロード、アンロードが可能。

シンボリックリンクはってるだけと違うのかな?よくわかりません。

[]phpのインストールとか phpのインストールとか - 雲雀は高く空を舞い を含むブックマーク はてなブックマーク - phpのインストールとか - 雲雀は高く空を舞い phpのインストールとか - 雲雀は高く空を舞い のブックマークコメント

wordpressを入れる際に参考にしたページ

ipod video by ffmpeg  ipod video by ffmpeg - 雲雀は高く空を舞い を含むブックマーク はてなブックマーク -  ipod video by ffmpeg - 雲雀は高く空を舞い  ipod video by ffmpeg - 雲雀は高く空を舞い のブックマークコメント

できた(たぶん)

http://penta.zaniah.net/index.php?ffmpeg より

./ffmpeg -i 【InputFile】 -f mp4 -vcodec h264 -b 2000 -ac 2 -ab 96 -ar 44000 【output.mp4】

ffmpegを使ってH.264形式にムーヴィーを変換。  ffmpegを使ってH.264形式にムーヴィーを変換。 - 雲雀は高く空を舞い を含むブックマーク はてなブックマーク -  ffmpegを使ってH.264形式にムーヴィーを変換。 - 雲雀は高く空を舞い  ffmpegを使ってH.264形式にムーヴィーを変換。 - 雲雀は高く空を舞い のブックマークコメント

結局、以下のようにしてディレクトリ内のflvファイルをすべて変換。しかし、出来たファイルはvlcでは見れるけどquicktimeでは再生されない。んむー。

ls *.flv | ruby -ne '$_.chop!;a=$_.sub(/flv$/,"mp4");puts `ffmpeg -i #{$_} -vcodec h264 -b 800 -s 320x240 -acodec aac -ar 44100 -ab 128 #{a}`'

続く。

[] ffmpegコーデックを色々インストール  ffmpegコーデックを色々インストール - 雲雀は高く空を舞い を含むブックマーク はてなブックマーク -  ffmpegコーデックを色々インストール - 雲雀は高く空を舞い  ffmpegコーデックを色々インストール - 雲雀は高く空を舞い のブックマークコメント

先ほど入れたffmpegではH.264形式が作れなかったので、po-ru.com: Fixing ffmpeg on Ubuntu Edgyを参考に色々インストール。

まずはffmpegのアンインストール

sudo apt-get remove ffmpeg

んでもって、えいやっと。

sudo apt-get build-dep ffmpeg

sudo apt-get install liblame-dev libfaad2-dev libfaac-dev libxvidcore4-dev liba52-0.7.4 liba52-0.7.4-dev libx264-dev checkinstall build-essential

apt-get source ffmpeg

cd ffmpeg-*

./configure --enable-gpl --enable-pp --enable-vorbis --enable-libogg --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid --enable-pthreads --enable-x264

make

make install

make時に以下のエラーが発生

/home/can-can/ffmpeg-0.cvs20060823/version.sh "/home/can-can/ffmpeg-0.cvs20060823"

make -C libavutil all

make[1]: Entering directory `/home/can-can/ffmpeg-0.cvs20060823/libavutil'

make[1]: Nothing to be done for `all'.

make[1]: Leaving directory `/home/can-can/ffmpeg-0.cvs20060823/libavutil'

make -C libavcodec all

make[1]: Entering directory `/home/can-can/ffmpeg-0.cvs20060823/libavcodec'

gcc -DHAVE_AV_CONFIG_H -I.. -I/home/can-can/ffmpeg-0.cvs20060823/libavutil -O3 -pthread -Wdeclaration-after-statement -Wall -Wno-switch -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -c -o x264.o x264.c

x264.c: In function ‘X264_init’:

x264.c:147: error: ‘struct <anonymous>’ has no member named ‘i_rf_constant’

make[1]: *** [x264.o] Error 1

make[1]: Leaving directory `/home/can-can/ffmpeg-0.cvs20060823/libavcodec'

make: *** [lib] Error 2

http://ubuntuforums.org/showpost.php?p=2551048&postcount=456を参考に

you need to open /libavcodec/x264.c and goto line 147. Change i_rf_constant to f_rf_constant

てことで、該当部分を書き直してmake, make installで無事(?)インストールできた。無事かどうかは良く分からん。

intじゃまずいからfloatにしてるんだろうけど、これって良く使われるもののような器がするから、いまいち自分で修正が必要なんだかどうだか。まぁいいや。


[]ffmpegmplayerのインストール ffmpegとmplayerのインストール - 雲雀は高く空を舞い を含むブックマーク はてなブックマーク - ffmpegとmplayerのインストール - 雲雀は高く空を舞い ffmpegとmplayerのインストール - 雲雀は高く空を舞い のブックマークコメント

allegro@dolce:~$ sudo apt-get install ffmpeg

パッケージリストを読み込んでいます... 完了

依存関係ツリーを作成しています

Reading state information... 完了

以下のパッケージが新たにインストールされます:

ffmpeg

アップグレード: 0 個、新規インストール: 1 個、削除: 0 個、保留: 0 個。

181kB のアーカイブを取得する必要があります。

展開後に追加で 635kB のディスク容量が消費されます。

取得:1 http://jp.archive.ubuntu.com feisty/universe ffmpeg 3:0.cvs20060823-3.1ubuntu4 [181kB]

181kB を 5s で取得しました (33.5kB/s)

未選択パッケージ ffmpeg を選択しています。

(データベースを読み込んでいます ... 現在 126975 個のファイルとディレクトリがインストールされています。)

(.../ffmpeg_3%3a0.cvs20060823-3.1ubuntu4_i386.deb から) ffmpeg を展開しています...

ffmpeg (0.cvs20060823-3.1ubuntu4) を設定しています ...

allegro@dolce:~$ sudo apt-get install mplayer

パッケージリストを読み込んでいます... 完了

依存関係ツリーを作成しています

Reading state information... 完了

以下の特別パッケージがインストールされます:

libfaac0 libggi2 libgii1 libgii1-target-x libmp4v2-0 libpulse0 libxvidcore4 libxvmc1 mplayer-skins

提案パッケージ:

libggi-target-emu libggi-target-monotext libggimisc2 pulseaudio w32codecs libdvdcss mplayer-doc

ladspa-sdk

推奨パッケージ:

libggi-target-x libggi-target

以下のパッケージが新たにインストールされます:

libfaac0 libggi2 libgii1 libgii1-target-x libmp4v2-0 libpulse0 libxvidcore4 libxvmc1 mplayer

mplayer-skins

アップグレード: 0 個、新規インストール: 10 個、削除: 0 個、保留: 0 個。

5422kB のアーカイブを取得する必要があります。

展開後に追加で 14.3MB のディスク容量が消費されます。

続行しますか [Y/n]? y

取得:1 http://jp.archive.ubuntu.com feisty/multiverse libmp4v2-0 2.0.0+cvs20040908+mp4v2+bmp-0ubuntu3 [214kB]

取得:2 http://jp.archive.ubuntu.com feisty/multiverse libfaac0 1.24clean-0ubuntu4 [55.2kB]

取得:3 http://jp.archive.ubuntu.com feisty/universe libgii1-target-x 1:1.0.1-3 [15.9kB]

取得:4 http://jp.archive.ubuntu.com feisty/universe libgii1 1:1.0.1-3 [235kB]

取得:5 http://jp.archive.ubuntu.com feisty/universe libggi2 1:2.2.1-5ubuntu1 [481kB]

取得:6 http://jp.archive.ubuntu.com feisty/main libpulse0 0.9.5-5ubuntu4 [99.9kB]

取得:7 http://jp.archive.ubuntu.com feisty/multiverse libxvidcore4 2:1.1.2-0.1ubuntu1 [177kB]

取得:8 http://jp.archive.ubuntu.com feisty/main libxvmc1 2:1.0.2-0ubuntu2 [12.1kB]

取得:9 http://jp.archive.ubuntu.com feisty/multiverse mplayer-skins 2-6 [70.2kB]

取得:10 http://jp.archive.ubuntu.com feisty/multiverse mplayer 2:1.0~rc1-0ubuntu9 [4062kB]

5422kB を 6s で取得しました (788kB/s)

未選択パッケージ libmp4v2-0 を選択しています。

(データベースを読み込んでいます ... 現在 127007 個のファイルとディレクトリがインストールされています。)

(.../libmp4v2-0_2.0.0+cvs20040908+mp4v2+bmp-0ubuntu3_i386.deb から) libmp4v2-0 を展開しています...

未選択パッケージ libfaac0 を選択しています。

(.../libfaac0_1.24clean-0ubuntu4_i386.deb から) libfaac0 を展開しています...

未選択パッケージ libgii1-target-x を選択しています。

(.../libgii1-target-x_1%3a1.0.1-3_i386.deb から) libgii1-target-x を展開しています...

未選択パッケージ libgii1 を選択しています。

(.../libgii1_1%3a1.0.1-3_i386.deb から) libgii1 を展開しています...

未選択パッケージ libggi2 を選択しています。

(.../libggi2_1%3a2.2.1-5ubuntu1_i386.deb から) libggi2 を展開しています...

未選択パッケージ libpulse0 を選択しています。

(.../libpulse0_0.9.5-5ubuntu4_i386.deb から) libpulse0 を展開しています...

未選択パッケージ libxvidcore4 を選択しています。

(.../libxvidcore4_2%3a1.1.2-0.1ubuntu1_i386.deb から) libxvidcore4 を展開しています...

未選択パッケージ libxvmc1 を選択しています。

(.../libxvmc1_2%3a1.0.2-0ubuntu2_i386.deb から) libxvmc1 を展開しています...

未選択パッケージ mplayer-skins を選択しています。

(.../mplayer-skins_2-6_all.deb から) mplayer-skins を展開しています...

未選択パッケージ mplayer を選択しています。

(.../mplayer_2%3a1.0~rc1-0ubuntu9_i386.deb から) mplayer を展開しています...

libmp4v2-0 (2.0.0+cvs20040908+mp4v2+bmp-0ubuntu3) を設定しています ...

libfaac0 (1.24clean-0ubuntu4) を設定しています ...

libgii1-target-x (1.0.1-3) を設定しています ...

libgii1 (1.0.1-3) を設定しています ...

libggi2 (2.2.1-5ubuntu1) を設定しています ...

libpulse0 (0.9.5-5ubuntu4) を設定しています ...

libxvidcore4 (1.1.2-0.1ubuntu1) を設定しています ...

libxvmc1 (1.0.2-0ubuntu2) を設定しています ...

mplayer-skins (2-6) を設定しています ...

mplayer (1.0~rc1-0ubuntu9) を設定しています ...

テクノラティプロフィール